summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDamien Zammit <damien@zamaudio.com>2020-07-18 17:43:43 +0200
committerDamien Zammit <damien@zamaudio.com>2023-06-23 23:53:31 +1000
commit55a8277ba8230fcc8585a977dd57e4a19f1bfcc3 (patch)
tree30ad25a67505184bb4749475da2c1642fbb44c80
parent99462e362d0da8709f29227c586c088fc68f12e4 (diff)
patches/Wno-error.diff: Add -Wno-sign-compare for now (until device RPC is fixed)
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/Wno-error.diff3
2 files changed, 4 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index b808eeac..411bf6fc 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,8 @@ rumpkernel (0~20191130-2) UNRELEASED; urgency=medium
[ Damien Zammit ]
* patches/rumpuser-rng-debug.diff: WIP: Remove hardfail on missing
/dev/urandom for PRNG && add mach_print debug
+ * patches/Wno-error.diff: Add -Wno-sign-compare for now (until device RPC is
+ fixed)
-- Samuel Thibault <sthibault@debian.org> Sat, 18 Jul 2020 17:40:08 +0200
diff --git a/debian/patches/Wno-error.diff b/debian/patches/Wno-error.diff
index 5e25d90a..1b54758e 100644
--- a/debian/patches/Wno-error.diff
+++ b/debian/patches/Wno-error.diff
@@ -4,13 +4,14 @@
--- a/buildrump.sh/buildrump.sh
+++ b/buildrump.sh/buildrump.sh
-@@ -1067,6 +1067,10 @@ evaltoolchain ()
+@@ -1067,6 +1067,11 @@ evaltoolchain ()
;;
esac
+ appendvar EXTRA_CWARNFLAGS -Wno-error
+ appendvar EXTRA_CWARNFLAGS -Wno-error=format-security
+ appendvar EXTRA_CWARNFLAGS -Wno-error=stringop-truncation
++ appendvar EXTRA_CWARNFLAGS -Wno-sign-compare
+
if ! cppdefines __ELF__; then
${TITANMODE} || die ELF required as target object format