summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuel Thibault <samuel.thibault@ens-lyon.org>2020-03-30 08:19:08 +0000
committerDamien Zammit <damien@zamaudio.com>2023-06-23 23:50:19 +1000
commit06707ccdc1c202711aa47d17d74a355d4df6a738 (patch)
treef1627629f14f8dc15019e7556d4d1fe5db7e732d
parent4452cdd7f1bb5c8aafdcd2abbb9a667215373eca (diff)
Update to cleaned GNU Mach interrupt notification interface
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/gnumach-update26
-rw-r--r--debian/patches/series1
3 files changed, 28 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 6240d037..9f64c6ef 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -9,6 +9,7 @@ rumpkernel (0~20191130-1) unreleased; urgency=medium
[ Samuel Thibault ]
* Add missing zlib1g-dev build-dep.
* Add -Wno-error on linux too.
+ * Update to cleaned GNU Mach interrupt notification interface.
-- Samuel Thibault <sthibault@debian.org> Mon, 30 Mar 2020 00:24:11 +0000
diff --git a/debian/patches/gnumach-update b/debian/patches/gnumach-update
new file mode 100644
index 00000000..b8e70f25
--- /dev/null
+++ b/debian/patches/gnumach-update
@@ -0,0 +1,26 @@
+Index: rumpkernel/pci-userspace/src-gnu/pci_user-gnu.c
+===================================================================
+--- rumpkernel.orig/pci-userspace/src-gnu/pci_user-gnu.c
++++ rumpkernel/pci-userspace/src-gnu/pci_user-gnu.c
+@@ -65,7 +65,7 @@
+
+ #include "pci_user.h"
+ #include "experimental_U.h"
+-#include <device/intr.h>
++#include <device/notify.h>
+ #include "mach_debug_U.h"
+ #include <mach/vm_param.h>
+ #include <mach.h>
+@@ -307,10 +307,10 @@ intrthread(void *arg)
+ int irq_server (mach_msg_header_t *inp, mach_msg_header_t *outp) {
+ char interrupt[4];
+
+- mach_intr_notification_t *n = (mach_intr_notification_t *) inp;
++ device_intr_notification_t *n = (device_intr_notification_t *) inp;
+
+ ((mig_reply_header_t *) outp)->RetCode = MIG_NO_REPLY;
+- if (n->intr_header.msgh_id != MACH_INTR_NOTIFY) {
++ if (n->intr_header.msgh_id != DEVICE_INTR_NOTIFY) {
+ MACH_PRINT("not an interrupt\n");
+ return 0;
+ }
diff --git a/debian/patches/series b/debian/patches/series
index d2cf1258..475d88b6 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -5,3 +5,4 @@ piixide-rump.diff
ahcisata-rump.diff
busspaceunmap-rump.diff
memory-range.diff
+gnumach-update