summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Zammit <damien@zamaudio.com>2022-09-12 10:39:30 +0000
committerSamuel Thibault <samuel.thibault@ens-lyon.org>2022-09-12 20:32:24 +0200
commit160fb63ee0c72f165ab131c4d725d9badaa646ab (patch)
treeffb56a39d40b8e42213990ba5ce6f136eb9431ec /configure.ac
parent22676a3a6e4d99e13ee75c1ad2f4976ae6b0ce52 (diff)
acpi: Link translator to libacpica and provide RPCs
Provides two new acpi RPCs to sleep the machine and to get the irq of any pci device. ACPI mode is enabled by default when the translator is started. NB: Merging this commit means libacpica is a build dep. Message-Id: <20220912103837.556815-2-damien@zamaudio.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 07e84a5b..11cafa5f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -394,6 +394,15 @@ AC_SUBST([HAVE_LIBPCIACCESS])
AC_SUBST([libpciaccess_CFLAGS])
AC_SUBST([libpciaccess_LIBS])
+AC_CHECK_LIB(acpica, acpi_init, [
+ HAVE_LIBACPICA=yes
+ libacpica_LIBS="-lacpica"
+ libacpica_CFLAGS=""],
+ [HAVE_LIBACPICA=no])
+AC_SUBST([HAVE_LIBACPICA])
+AC_SUBST([libacpica_CFLAGS])
+AC_SUBST([libacpica_LIBS])
+
AC_CONFIG_FILES([config.make ${makefiles} daemons/runsystem.hurd.sh])
AC_OUTPUT