summaryrefslogtreecommitdiff
path: root/SConstruct
diff options
context:
space:
mode:
Diffstat (limited to 'SConstruct')
-rw-r--r--SConstruct45
1 files changed, 34 insertions, 11 deletions
diff --git a/SConstruct b/SConstruct
index 99bd85264b..d53cf624ad 100644
--- a/SConstruct
+++ b/SConstruct
@@ -16,7 +16,7 @@ import SCons.Node.FS
SConsignFile()
EnsureSConsVersion(0, 96)
-ardour_version = '2.0beta11.1'
+ardour_version = '2.0rc1'
subst_dict = { }
@@ -41,9 +41,11 @@ opts.AddOptions(
PathOption('PREFIX', 'Set the install "prefix"', '/usr/local'),
BoolOption('SURFACES', 'Build support for control surfaces', 1),
BoolOption('SYSLIBS', 'USE AT YOUR OWN RISK: CANCELS ALL SUPPORT FROM ARDOUR AUTHORS: Use existing system versions of various libraries instead of internal ones', 0),
+ BoolOption('UNIVERSAL', 'Compile as universal binary. Requires that external libraries are already universal.', 0),
BoolOption('VERSIONED', 'Add revision information to ardour/gtk executable name inside the build directory', 0),
BoolOption('VST', 'Compile with support for VST', 0),
- BoolOption('TRANZPORT', 'Compile with support for Frontier Designs (if libusb is available)', 0)
+ BoolOption('GPROFILE', 'Compile with support for gprofile (Developers only)', 0),
+ BoolOption('TRANZPORT', 'Compile with support for Frontier Designs (if libusb is available)', 1)
)
#----------------------------------------------------------------------
@@ -311,7 +313,7 @@ env.Append (BUILDERS = {'VersionBuild' : version_bld})
#
def versioned_builder(target,source,env):
- w, r = os.popen2( "svn info | awk '/^Revision:/ { print $2}'")
+ w, r = os.popen2( "LANG= svn info | awk '/^Revision:/ { print $2}'")
last_revision = r.readline().strip()
w.close()
@@ -540,7 +542,10 @@ env = conf.Finish()
#
opt_flags = []
-debug_flags = [ '-g' ]
+if env['GPROFILE'] == 1:
+ debug_flags = [ '-g', '-pg' ]
+else:
+ debug_flags = [ '-g' ]
# guess at the platform, used to define compiler flags
@@ -606,7 +611,7 @@ elif ((re.search ("i[0-9]86", config[config_cpu]) != None) or (re.search ("x86_6
if env['DIST_TARGET'] != 'i386':
flag_line = os.popen ("cat /proc/cpuinfo | grep '^flags'").read()[:-1]
- x86_flags = flag_line.split (": ")[1:][0].split (' ')
+ x86_flags = flag_line.split (": ")[1:][0].split ()
if "mmx" in x86_flags:
opt_flags.append ("-mmmx")
@@ -670,13 +675,19 @@ opt_flags[:0] = [
"-fomit-frame-pointer",
"-ffast-math",
"-fstrength-reduce",
- "-fno-strict-aliasing"
+ "-pipe"
]
if env['DEBUG'] == 1:
env.Append(CCFLAGS=" ".join (debug_flags))
+ env.Append(LINKFLAGS=" ".join (debug_flags))
else:
env.Append(CCFLAGS=" ".join (opt_flags))
+ env.Append(LINKFLAGS=" ".join (opt_flags))
+
+if env['UNIVERSAL'] == 1:
+ env.Append(CCFLAGS="-arch i386 -arch ppc")
+ env.Append(LINKFLAGS="-arch i386 -arch ppc")
#
# warnings flags
@@ -686,8 +697,9 @@ env.Append(CCFLAGS="-Wall")
env.Append(CXXFLAGS="-Woverloaded-virtual")
if env['EXTRA_WARN']:
- env.Append(CCFLAGS="-Wextra -pedantic")
+ env.Append(CCFLAGS="-Wextra -pedantic -ansi")
env.Append(CXXFLAGS="-ansi")
+# env.Append(CFLAGS="-iso")
if env['LIBLO']:
env.Append(CCFLAGS="-DHAVE_LIBLO")
@@ -726,7 +738,8 @@ prep_libcheck(env, libraries['flac'])
libraries['flac'].Append(CCFLAGS="-I/usr/local/include", LINKFLAGS="-L/usr/local/lib")
conf = Configure (libraries['flac'])
-conf.CheckLib ('FLAC', 'FLAC__stream_decoder_new', language='CXX')
+if conf.CheckLib ('FLAC', 'FLAC__stream_decoder_new', language='CXX'):
+ conf.env.Append(CCFLAGS='-DHAVE_FLAC')
libraries['flac'] = conf.Finish ()
# or if that fails...
@@ -840,7 +853,7 @@ if env['SYSLIBS']:
libraries['sndfile-ardour'] = LibraryInfo(LIBS='libsndfile-ardour',
LIBPATH='#libs/libsndfile',
- CPPPATH=['#libs/libsndfile', '#libs/libsndfile/src'])
+ CPPPATH=['#libs/libsndfile/src'])
# libraries['flowcanvas'] = LibraryInfo(LIBS='flowcanvas', LIBPATH='#/libs/flowcanvas', CPPPATH='#libs/flowcanvas')
libraries['soundtouch'] = LibraryInfo()
@@ -958,11 +971,14 @@ else:
# its included in the tarball
#
-surface_subdirs = [ 'libs/surfaces/control_protocol', 'libs/surfaces/generic_midi', 'libs/surfaces/tranzport' ]
+surface_subdirs = [ 'libs/surfaces/control_protocol', 'libs/surfaces/generic_midi', 'libs/surfaces/tranzport', 'libs/surfaces/mackie' ]
if env['SURFACES']:
if have_libusb:
- env['TRANZPORT'] = 'yes'
+ env['TRANZPORT'] = 1
+ else:
+ env['TRANZPORT'] = 0
+ print 'Disabled building Tranzport code because libusb could not be found'
if os.access ('libs/surfaces/sony9pin', os.F_OK):
surface_subdirs += [ 'libs/surfaces/sony9pin' ]
@@ -1069,6 +1085,13 @@ if not conf.CheckFunc('posix_memalign'):
env = conf.Finish()
rcbuild = env.SubstInFile ('ardour.rc','ardour.rc.in', SUBST_DICT = subst_dict)
+subst_dict['%VERSION%'] = ardour_version[0:3]
+subst_dict['%EXTRA_VERSION%'] = ardour_version[3:]
+subst_dict['%REVISION_STRING%'] = ''
+if os.path.exists('.svn'):
+ subst_dict['%REVISION_STRING%'] = '.' + fetch_svn_revision ('.') + 'svn'
+
+# specbuild = env.SubstInFile ('ardour.spec','ardour.spec.in', SUBST_DICT = subst_dict)
the_revision = env.Command ('frobnicatory_decoy', [], create_stored_revision)