summaryrefslogtreecommitdiff
path: root/utils/aurez/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'utils/aurez/Makefile')
-rw-r--r--utils/aurez/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/utils/aurez/Makefile b/utils/aurez/Makefile
new file mode 100644
index 00000000..122a2615
--- /dev/null
+++ b/utils/aurez/Makefile
@@ -0,0 +1,26 @@
+PREFIX ?= /usr/local
+CXX ?= g++
+CXXFLAGS ?= -O2 -g -Wall -std=c++11
+LDFLAGS ?=
+
+all: bin/AuRez
+
+clean:
+ rm -rf bin obj
+
+install: all
+ install -D -m 755 bin/AuRez $(DESTDIR)$(PREFIX)/bin/AuRez
+
+.PHONY: all clean install
+
+obj/%.o: %.cc
+ @mkdir -p obj
+ $(CXX) $(CXXFLAGS) -c -o $@ $<
+
+bin/AuRez: obj/AuRez.o obj/AuRsrc.o obj/MacRsrc.o
+ @mkdir -p bin
+ $(CXX) $(LDFLAGS) -o $@ $^
+
+AuRez.cc: AuRsrc.h MacRsrc.h
+AuRsrc.cc: AuRsrc.h
+MacRsrc.cc: MacRsrc.h