summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2023-05-16 10:57:49 +0200
committerDamien Zammit <damien@zamaudio.com>2023-06-24 00:00:18 +1000
commit1d7bb244c22c0def99af2d87b45d82604d64dd00 (patch)
tree6b8978bbc1a315028c4c32596b374bc5f9aaa280
parentde0a306542be54660f3508f98a253cc3dcc0e6a9 (diff)
crossbuild: Cater for non-FHS shell.
* debian/patches/non-fhs-shell: New file. * debian/patches/series: Add it. Message-Id: <20230516085750.32095-3-janneke@gnu.org>
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/non-fhs-shell37
-rw-r--r--debian/patches/series1
3 files changed, 39 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 78cdf1c2..c12cf5b7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,7 @@ rumpkernel (0~20211031-4) UNRELEASED; urgency=medium
[ Janneke Nieuwenhuizen ]
* debian/patches/crossbuild: Fix cross-builds on Arch.
+ * debian/patches/non-fhs-shell: Cater for non-FHS shell.
-- Samuel Thibault <sthibault@debian.org> Tue, 16 May 2023 13:55:58 +0200
diff --git a/debian/patches/non-fhs-shell b/debian/patches/non-fhs-shell
new file mode 100644
index 00000000..a8a1af12
--- /dev/null
+++ b/debian/patches/non-fhs-shell
@@ -0,0 +1,37 @@
+Cater for SH not being in /BIN, avoiding "#! /gnu/store/bash-0/bin/sh"
+to be subsituted with "#! /gnu/store/bash-0/gnu/store/bash-0/bin/sh".
+
+---
+ buildrump.sh/src/tools/genassym/Makefile | 2 +-
+ buildrump.sh/src/tools/lorder/Makefile | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/buildrump.sh/src/tools/genassym/Makefile b/buildrump.sh/src/tools/genassym/Makefile
+index e597c522b..96ca4ac21 100644
+--- a/buildrump.sh/src/tools/genassym/Makefile
++++ b/buildrump.sh/src/tools/genassym/Makefile
+@@ -17,7 +17,7 @@ ${TIMESTAMP}: genassym
+ ${HOST_INSTALL_FILE} -m ${BINMODE} ${.ALLSRC} ${.TARGET}
+
+ genassym: genassym.sh
+- ${TOOL_SED} -e "s,/bin/sh,${HOST_BSHELL},g" \
++ ${TOOL_SED} -e "s,\([ \!]\)/bin/sh,\1${HOST_BSHELL},g" \
+ -e "s,{AWK:=.*},{AWK:="${TOOL_AWK:Q}"}," \
+ < ${.ALLSRC} > ${.TARGET}
+
+diff --git a/buildrump.sh/src/tools/lorder/Makefile b/buildrump.sh/src/tools/lorder/Makefile
+index f3c599e12..92af83d51 100644
+--- a/buildrump.sh/src/tools/lorder/Makefile
++++ b/buildrump.sh/src/tools/lorder/Makefile
+@@ -17,7 +17,7 @@ ${TIMESTAMP}: lorder
+ ${HOST_INSTALL_FILE} -m ${BINMODE} ${.ALLSRC} ${.TARGET}
+
+ lorder: lorder.sh
+- ${TOOL_SED} -e "s,/bin/sh,"${HOST_BSHELL:Q}",g" \
++ ${TOOL_SED} -e "s,\([ \!]\)/bin/sh,\1"${HOST_BSHELL:Q}",g" \
+ -e "s,{JOIN:=.*},{JOIN:="${TOOL_JOIN:Q}"}," \
+ -e "s,{MKTEMP:=.*},{MKTEMP:="${TOOL_MKTEMP:Q}"}," \
+ -e "s,{NM:=.*},{NM:="${NM:Q}"}," \
+--
+2.39.2
+
diff --git a/debian/patches/series b/debian/patches/series
index c0df4b80..0eddd6bf 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -19,3 +19,4 @@ linux
crossbuild
clean_libpci
random
+non-fsh-shell