summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuel Thibault <samuel.thibault@ens-lyon.org>2023-05-07 15:29:38 +0000
committerDamien Zammit <damien@zamaudio.com>2023-06-24 00:00:16 +1000
commit0851cba649dccf8bb39402cc29f621ca44d6b3a5 (patch)
tree7b64d21c84dbb8f2c1d1596ef1b591f0caffae61
parent716e8c686de679f107d9c65d65d4b9235871e132 (diff)
patches/random: Do not use arc4random_buf: during bootstrap we don't have it
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/random15
-rw-r--r--debian/patches/series1
3 files changed, 18 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index d0f853c3..b5cb10f6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -8,6 +8,8 @@ rumpkernel (0~20211031-3) UNRELEASED; urgency=medium
* debian/patches/linux: Fix build on Linux.
* debian/patches/crossbuild: Fix cross-builds.
* debian/rules: Fix cross-build.
+ * patches/random: Do not use arc4random_buf: during bootstrap we don't have
+ it.
-- Samuel Thibault <sthibault@debian.org> Thu, 19 Jan 2023 00:53:29 +0100
diff --git a/debian/patches/random b/debian/patches/random
new file mode 100644
index 00000000..72fc9f44
--- /dev/null
+++ b/debian/patches/random
@@ -0,0 +1,15 @@
+Do not use arc4random_buf: during bootstrap we don't have it
+
+Index: rumpkernel-0~20211031/buildrump.sh/src/lib/librumpuser/rumpuser_random.c
+===================================================================
+--- rumpkernel-0~20211031.orig/buildrump.sh/src/lib/librumpuser/rumpuser_random.c
++++ rumpkernel-0~20211031/buildrump.sh/src/lib/librumpuser/rumpuser_random.c
+@@ -46,6 +46,8 @@ __RCSID("$NetBSD: rumpuser_random.c,v 1.
+
+ #include "rumpuser_int.h"
+
++#undef HAVE_ARC4RANDOM_BUF
++
+ static const size_t random_maxread = 32;
+
+ #ifdef HAVE_ARC4RANDOM_BUF
diff --git a/debian/patches/series b/debian/patches/series
index 08fe9671..c0df4b80 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -18,3 +18,4 @@ idtype_t.diff
linux
crossbuild
clean_libpci
+random