summaryrefslogtreecommitdiff
path: root/libs/taglib/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libs/taglib/tests/CMakeLists.txt')
-rw-r--r--libs/taglib/tests/CMakeLists.txt35
1 files changed, 0 insertions, 35 deletions
diff --git a/libs/taglib/tests/CMakeLists.txt b/libs/taglib/tests/CMakeLists.txt
deleted file mode 100644
index 88c08098e1..0000000000
--- a/libs/taglib/tests/CMakeLists.txt
+++ /dev/null
@@ -1,35 +0,0 @@
-if(BUILD_TESTS)
-
-INCLUDE_DIRECTORIES(
- ${CMAKE_CURRENT_SOURCE_DIR}/../taglib
- ${CMAKE_CURRENT_SOURCE_DIR}/../taglib/toolkit
- ${CMAKE_CURRENT_SOURCE_DIR}/../taglib/mpeg/id3v1
- ${CMAKE_CURRENT_SOURCE_DIR}/../taglib/mpeg/id3v2
- ${CMAKE_CURRENT_SOURCE_DIR}/../taglib/mpeg/id3v2/frames
- ${CMAKE_CURRENT_SOURCE_DIR}/../taglib/mpeg
- ${CMAKE_CURRENT_SOURCE_DIR}/../taglib/trueaudio
-)
-
-SET(test_runner_SRCS
- main.cpp
- test_list.cpp
- test_map.cpp
- test_mpeg.cpp
- test_synchdata.cpp
- test_trueaudio.cpp
- test_bytevector.cpp
- test_string.cpp
- test_fileref.cpp
- test_id3v1.cpp
- test_id3v2.cpp
-)
-
-ADD_EXECUTABLE(test_runner ${test_runner_SRCS})
-TARGET_LINK_LIBRARIES(test_runner tag ${CPPUNIT_LIBRARIES})
-
-ADD_CUSTOM_TARGET(check
- ./test_runner
- DEPENDS test_runner
-)
-
-endif(BUILD_TESTS)