summaryrefslogtreecommitdiff
path: root/libs/cassowary/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libs/cassowary/Makefile.am')
-rw-r--r--libs/cassowary/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/libs/cassowary/Makefile.am b/libs/cassowary/Makefile.am
new file mode 100644
index 0000000000..fb36aef47c
--- /dev/null
+++ b/libs/cassowary/Makefile.am
@@ -0,0 +1,32 @@
+MAINTAINERCLEANFILES = autom4te.cache Makefile.in aclocal.m4 configure \
+ config.h.in stamp-h.in config.guess mkinstalldirs \
+ missing install-sh config.sub ltconfig \
+ ltmain.sh acinclude.m4 config.log config.status \
+ depcomp ClReader.cc ClReader.hh ClReader-lex.cc
+
+EXTRA_DIST = ClReader.l ClReader.y
+
+SUBDIRS = cassowary
+
+noinst_LIBRARIES = libcassowary.a
+
+libcassowary_a_SOURCES = \
+ ClAbstractVariable.cc \
+ ClConstraint.cc \
+ ClLinearExpression.cc \
+ ClSolver.cc \
+ ClSimplexSolver.cc \
+ ClStrength.cc \
+ ClSymbolicWeight.cc \
+ ClTableau.cc \
+ ClVariable.cc \
+ ClFloatVariable.cc \
+ ClSlackVariable.cc \
+ ClDummyVariable.cc \
+ ClReader-lex.cc
+
+ClReader-lex.cc: ClReader.l cassowary/ClReader.h ClReader.cc
+ $(LEX) -Pcl -o$@ $<
+
+ClReader.cc: ClReader.y cassowary/ClReader.h
+ $(YACC) -d -pcl --output-file $@ $<