summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSamuel Pitoiset <samuel.pitoiset@gmail.com>2014-01-18 17:19:14 +0100
committerJon TURNEY <jon.turney@dronecode.org.uk>2014-01-27 23:39:48 +0000
commit6bfccc7ec4f0705595385f6684b6849663f781b4 (patch)
tree8fc059d191c7cde1d633f5e221c8f508127fa31c /configure.ac
parent06f562584a885eff7366dca82caf746e62b5a21f (diff)
Windows/Cygwin: Add support through the WinIo library
V2: - Add support for unmapping - Add a README.cygwin Reviewed-by: Martin Peres <martin.peres@free.fr> Reviewed-by: Jon TURNEY <jon.turney@dronecode.org.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fe3b78e..e3f7d8b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -95,6 +95,10 @@ case $host_os in
gnu*)
gnu=yes
;;
+ *cygwin*)
+ cygwin=yes
+ PCIACCESS_LIBS="$PCIACCESS_LIBS"
+ ;;
esac
AM_CONDITIONAL(LINUX, [test "x$linux" = xyes])
@@ -103,6 +107,7 @@ AM_CONDITIONAL(NETBSD, [test "x$netbsd" = xyes])
AM_CONDITIONAL(OPENBSD, [test "x$openbsd" = xyes])
AM_CONDITIONAL(SOLARIS, [test "x$solaris" = xyes])
AM_CONDITIONAL(GNU, [test "x$gnu" = xyes])
+AM_CONDITIONAL(CYGWIN, [test "x$cygwin" = xyes])
AC_SYS_LARGEFILE