summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2010-08-22 08:10:23 -0400
committerGaetan Nadon <memsize@videotron.ca>2010-10-03 14:02:44 -0400
commitdcb79a20cba1eaaa83158b80bb538d50b003bd79 (patch)
treea008d7a865b261e973541937980bd1e5bf3f36b5 /Makefile.am
parent555772964820d88f9481eb48d0431dddd8ba7aa5 (diff)
config: provide a makefile for scanpci dev tool
No function changes. Note that automake generates a wrapper script if libpciaccess is not installed at configuration time, which is the most common case. If it is installed at configuration time, you get an executable. The makefile build order ensures the lib is build before scanpci. Reviewed-by: RĂ©mi Cardona <remi@gentoo.org> Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index ff8db2f..31d20a0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,13 +24,14 @@
# Include autoconf macros from m4 subdir
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = src
+# Order: scanpci depends on libpciaccess built in src
+SUBDIRS = src scanpci
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = pciaccess.pc
MAINTAINERCLEANFILES = ChangeLog INSTALL
-EXTRA_DIST = src/scanpci.c src/scanpci.man
+EXTRA_DIST = src/scanpci.man
.PHONY: ChangeLog INSTALL