summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Cloos <cloos@jhcloos.com>2007-12-06 16:38:51 -0500
committerJames Cloos <cloos@jhcloos.com>2007-12-06 16:38:51 -0500
commitceda00d33fbf3d491e3f7e53302acd2b8b74a305 (patch)
treef59c2067302259608801e5f82e2822efd6236dd4 /Makefile.am
parente392082abb5696c8837224da86cc0af4f21d7010 (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index bf7eb7d..214721b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,3 +27,13 @@ pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = pciaccess.pc
EXTRA_DIST = pciaccess.pc.in autogen.sh src/scanpci.c
+
+EXTRA_DIST += ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog