summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDiego Nieto Cid <dnietoc@gmail.com>2015-06-05 00:28:19 -0300
committerJustus Winter <4winter@informatik.uni-hamburg.de>2015-06-05 18:34:02 +0200
commitf397f7c9c2a864f6496732a1406ed1f546cf3ad6 (patch)
tree03674f7b076382b60d2386f76fdaa27398ba2c9c /configure.ac
parentdb48e1651302797806f5656c856cf22e73761ea5 (diff)
Check AWK usability when XKB is enabled
* configure.ac: test whether AWK provides strtonum function.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 71f3a0ee..b03057bc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -292,6 +292,14 @@ PKG_CHECK_MODULES([X11], [x11 xproto],
have_x11=no])
], [have_x11=no])
])
+
+AS_IF([test "$have_x11" = "yes"],
+ [AC_MSG_CHECKING([whether AWK is usable])
+ AS_IF([test "$AWK" != ":" && $AWK 'BEGIN { strtonum("1"); }' 2>/dev/null],
+ [AC_MSG_RESULT([yes])],
+ [AC_MSG_RESULT([no])
+ AC_MSG_ERROR([$AWK does not provide required strtonum function])])])
+
AC_SUBST([have_x11])
AC_SUBST([XKB_BASE])
AC_DEFINE_UNQUOTED([X11_PREFIX], "$X11_PREFIX")