summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJustus Winter <4winter@informatik.uni-hamburg.de>2013-09-02 10:55:24 +0200
committerSamuel Thibault <samuel.thibault@ens-lyon.org>2013-09-09 09:52:32 +0200
commit96f54b8bc892bc6feee6b9a3878b23e8dcbb2004 (patch)
tree7c2e2a41edf3255ce0c0b474052a7316b8f42654 /configure.ac
parentc3a70032aa37e72adea05f03f5f8555e0991b560 (diff)
mount: handle -t auto
Use libblkid to detect the filesystem type if "auto" is given as type. Remove the translator localization from main, this is also done in do_mount and any errors are propagated properly. This way "auto" is handled correctly if given on the command line or used as filesystem type in the fstab. * configure.ac: Add check for libblkid. * config.make.in: Make libblkid specific values available. * utils/Makefile: Use libblkid specific values. * utils/mount.c (DEFAULT_FSTYPE): Use "auto" as default type. (do_mount): Detect type using libblkid. (main): Drop translator localization.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d40c01fb..5340b508 100644
--- a/configure.ac
+++ b/configure.ac
@@ -303,6 +303,12 @@ PKG_CHECK_MODULES([libdaemon], [libdaemon],
AC_SUBST([libdaemon_LIBS])
AC_SUBST([libdaemon_CFLAGS])
+PKG_CHECK_MODULES([libblkid], [blkid],
+ [AC_DEFINE([HAVE_BLKID], [1], [Use libblkid])],
+ [true])
+AC_SUBST([libblkid_LIBS])
+AC_SUBST([libblkid_CFLAGS])
+
AC_CONFIG_FILES([config.make ${makefiles}])
AC_OUTPUT