summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDamien Zammit <damien@zamaudio.com>2021-11-12 19:41:14 +1100
committerDamien Zammit <damien@zamaudio.com>2023-06-23 23:59:55 +1000
commit1ecfb404d3360711a52ee836ce0b12633d38d42b (patch)
treef4d961a1921987142130bde23ffbfb058952133c
parent930a3ef1a893956a063e467afca0a17a26ce5dc9 (diff)
rules: Fix for CWARNFLAGS
-rwxr-xr-xdebian/rules9
1 files changed, 2 insertions, 7 deletions
diff --git a/debian/rules b/debian/rules
index 050341a1..f1238b34 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,12 +8,7 @@ export SHELL = bash
DEB_HOST_ARCH_OS ?= $(dpkg-architecture -qDEB_HOST_ARCH_OS)
HOST_CFLAGS = -fcommon
LDFLAGS ?= $(shell dpkg-buildflags --get LDFLAGS)
-CFLAGS ?= $(shell dpkg-buildflags --get CFLAGS) $(HOST_CFLAGS) \
- -Wno-error=stack-protector \
- -Wno-error=array-parameter \
- -Wno-error=stringop-overflow \
- -D_FILE_OFFSET_BITS=64 \
-
+CFLAGS ?= $(shell dpkg-buildflags --get CFLAGS) $(HOST_CFLAGS)
ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
@@ -42,7 +37,7 @@ override_dh_auto_build-arch:
-V TOOLS_BUILDRUMP=yes -V MKGROFF=no -V TOPRUMP="$(CURDIR)/buildrump.sh/src/sys/rump" \
-V BUILDRUMP_CPPFLAGS="-Wno-error=stringop-overread" \
-V RUMPUSER_EXTERNAL_DPLIBS=pthread \
- -V CWARNFLAGS="-Wno-error=maybe-uninitialized -Wno-error=address-of-packed-member -Wno-error=unused-variable" \
+ -V CWARNFLAGS="-Wno-error=maybe-uninitialized -Wno-error=address-of-packed-member -Wno-error=unused-variable -Wno-error=stack-protector -Wno-error=array-parameter -Wno-error=array-bounds -Wno-error=stringop-overflow -D_FILE_OFFSET_BITS=64" \
-V LIBCRTBEGIN=" " -V LIBCRTEND=" " -V LIBCRT0=" " -V LIBCRTI=" " \
-V _GCC_CRTENDS=" " -V _GCC_CRTEND=" " \
-V _GCC_CRTBEGINS=" " -V _GCC_CRTBEGIN=" " \