summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPetr Salinger <petr.salinger@seznam.cz>2008-10-11 20:22:28 +0200
committerJulien Cristau <jcristau@debian.org>2008-10-11 20:29:11 +0200
commit6ae378611bb4caaf57311734d3adcb7e10ac3622 (patch)
tree9ba630e37006338b3b9c2cdfc77a1f373e828467 /configure.ac
parent968289fc3137ac0863c62d3c343153fa3e4aeb10 (diff)
Add support for GNU/kFreeBSD
We need to initialize the FreeBSD backend on GNU/kFreeBSD and detect whether pci_io.pi_sel.pc_domain member exists. X.Org bug#17882 <http://bugs.freedesktop.org/show_bug.cgi?id=17882>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8d97ae2..1cceb14 100644
--- a/configure.ac
+++ b/configure.ac
@@ -110,6 +110,14 @@ if test "x$have_mtrr_h" = xyes; then
AC_DEFINE(HAVE_MTRR, 1, [Use MTRRs on mappings])
fi
+dnl check for the pci_io.pi_sel.pc_domain
+AC_CHECK_MEMBER([struct pci_io.pi_sel.pc_domain],
+ [AC_DEFINE(HAVE_PCI_IO_PC_DOMAIN,1,[Have the pci_io.pi_sel.pc_domain member.])],
+ [],
+ [ #include <sys/types.h>
+ #include <sys/pciio.h>
+ ])
+
AC_SUBST(PCIACCESS_CFLAGS)
AC_SUBST(PCIACCESS_LIBS)