summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlmudena Garcia <liberamenso10000@gmail.com>2019-10-31 01:53:52 +0100
committerSamuel Thibault <samuel.thibault@ens-lyon.org>2019-10-31 01:59:00 +0100
commitd8671bc2a0fead7655b9e80736db33d84f14025c (patch)
tree11bc9379bf6946619b42789370a43dfe131fb068 /configure.ac
parent40ab805df48b2f65d5028ba59063e2a36f19f452 (diff)
proc: add support for last_processor
Read last_processor (new member) from thread_info structures, and fill stat structure with this. * configure.ac: Check whether thread_sched_info structure includes `last_processor' member. * proc/info.c (S_proc_getprocinfo) [HAVE_STRUCT_THREAD_SCHED_INFO_LAST_PROCESSOR]: Set `last_processor' field. * procfs/process.c (process_file_gc_stat) [HAVE_STRUCT_THREAD_SCHED_INFO_LAST_PROCESSOR]: Set last processor proc field to `thsi->last_processor'. [!HAVE_STRUCT_THREAD_SCHED_INFO_LAST_PROCESSOR]: Set last processor proc field to 0.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d0d03e8d..afa7e1e5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -347,6 +347,10 @@ AS_IF([test "x$with_libdaemon" != xno], [
AC_SUBST([libdaemon_LIBS])
AC_SUBST([libdaemon_CFLAGS])
+
+AC_CHECK_MEMBERS([struct thread_sched_info.last_processor],,,
+ [#include <mach/thread_info.h])
+
PKG_CHECK_MODULES([libblkid], [blkid],
[AC_DEFINE([HAVE_BLKID], [1], [Use libblkid])],
[true])